Le Forum des Catacombes de Port Libre

Might, Magic et les autres :)

Nombre total de posts : 15535

Might and Magic VI - Problème dans le jeu

Sujet : Oeil Maléfique! grrrrr

23 messages
Le 31/03/2009 à 22h45
Utilisateur
Nb Posts : 9
Oeil Maléfique! grrrrr
Bonjour à tous!

Je suis heureux qu'il reste un irreductible forum qui résiste encore et toujours a l'usure du temps!

Voila, je possedais le jeu il y a treeeees longtemps (depuis sa sortie, en 98 il me semble).
Bref en ce temps là, ce jeu m'avait fait une immense impression (rien que par la taille de son univers) mais, hélas, très/trop dur pour les néophytes, aussi, après quelques mois et voyant que je n'arrivais toujours pas a finir la tour des gobelins, je décidais d'abandonner le jeu.

Et puis, récemment, une irrépressible envie d'y rejouer me titillais et, après l'avoir installer sur mon vista, recommençais une magnifique aventure. (la difficulté n'avait pas changé depuis toutes ces années mais je me suis amélioré avec le temps ainsi qu'avec les conseils des gens de ce forum que je remercie)

Par contre j'ai quelques erreurs qui m'empêche de finir proprement le jeu!
La première, bénigne:
Dans le laboratoire d'Agar, a chaque combat contre des yeux maléfiques (les marrons seulement, pas les noirs), ils me lance un sort bizarre qui me plante le jeu!
ca m'affiche une erreur:
echec de l'assertion à 2118 dans D:MM6SrccodePARTY.CPP

Je fais OK mais ca me ferme le jeu...

Par contre la deuxième est plus embêtante car elle bloque une quête principale:
Quand je veux rentrer dans le château de la fange des damnés, ca me plante le jeu avec comme erreur AppCrash et toute une suite de code que seul microsoft peux comprendre (et encore, quand on les appelle il nous renvoie poliment sur leur site d'aide en ligne dont le lien est mort...)

En bref: au secours! Et merci d'avance!
Le 31/03/2009 à 23h54
Administrateur
avatar de Asumbaa
Paris
Nb Posts : 3193
Salut,

Argh... Des erreurs Microsoft :-|
T'es vraiment attaché à Bill ? Non parce que ça tourne nickel sous Linux à présent :-D

Bon, je t'aide pas beaucoup là, et j'en suis désolée... C'est pas trop mon rayon (y a-t-il seulement quelqu'un dont ce soit le rayon ? Un égyptologue peut-être ?)

À tout hasard, as-tu patché le jeu ou pas ?
"Le jeu est un défi de l'intelligence à la raison"
Le 01/04/2009 à 01h58
Utilisateur
Nb Posts : 9
erf, c'est bien ce que je redoutais... :,-(

Bon j'avoue, après tout ce temps, je ne retrouvais pas le CD original donc je l'ai téléchargé en abandonware (les fichiers sont des images CD). Je n'ai pas pus le patché car quand j'essaie d'installer le patch, ca me dit qu'il y a un fichier déja présent et qu'il faut le supprimer pour l'installer (traduit de l'anglais, hein?)

Et puis linux, j'y connais rien, moi! Je m'y connais assez pour faire une resto de système mais pour partager un disque dur en deux partie avec deux OS, j'ai trop peur de tout faire planté définitivement (un ordi a 1300¤, j'ai pas les moyens de m'en repayer un pareil! Y'a des erreurs enervantes mais on peut jouer en ligne sans lag, ce qui est rare)

Bon en bref, je suis obligé d'utiliser l'éditeur de sauvegarde, quoi! Je saurais jamais ce qu'il se passe dans ce labo ni dans ce château, snif!
Merci tout de même de ta réponse! :p
Le 01/04/2009 à 04h09
  • Ami du Forum
avatar de im_in_fire
Ton placard.
Nb Posts : 538
Hmmm, peut-être qu'une réinstallation pourrai aider? Si l'installation ne suffit pas, c'est sois un bug de Microsoft Vista (tu possèdes une version 32 ou 64 bit?), sois un bug dans l'image dispo sur LTF.
Oubliez la réalité, ma version des faits est bien meilleure!
http://miminee.labrute.fr
Le 01/04/2009 à 12h12
Utilisateur
Nb Posts : 9
C'est la version 32 bits.
J'ai déjà essayé avec deux versions en image CD (une anglaise et une francaise (c'est mieux en francais^^)) mais ca fait le même problème.

J'avais la même erreur AppCrash quand je lançais le jeu Black and White 2 et il avait disparu quand j'avais installé une autre version du jeu mais là, il resiste!

GRRRRR pourquoi ils nous forcent a prendre Vista sur ces fichus ordinateurs! :-(

Petite précision, pour les yeux maléfiques, on dirait que le sort qui fait planté serait l'emprisonnement du vide?
Au pire, personne n'aurait un fichier PARTY.CPP a me prêter? voir si en le remplaçant avec un moins capricieux ca fonctionne?

Merci pour vos réponses!
Le 01/04/2009 à 17h34
Utilisateur
Nb Posts : 9
Erratum, il semble que ce soit le sort qui rend fou! même dans la forge de gharik, les magiciens me font planter le jeu! (alors que ca me le faisait pas avant!) :-?

Bon je vais apprendre a nager a mon ordi! 8-D

Au fait petite astuce pour apporter ma pierre a l'edifice: On peut faire des déplacement latéraux en restant appuyé sur CTRL+ gauche ou droite! :-)
Le 01/04/2009 à 19h06
  • Enquêteur
avatar de Ramsès
Toulouse
Nb Posts : 1198
De toute façon il y a aussi des yeux dans le château de la fange. C'est dommage de sauter cette partie du jeu, c'est la plus chiante et donc celle qui procure le plus de satisfaction une fois terminée ^^

Je veux bien t'envoyer PARTY.CPP si jamais je le trouve. En espérant que ça aide. :-D

EDIT : Bah je le vois pas. Il doit être casé dans un des gros fichiers d'animation. :-| Décidément ces yeux, on pensait pas qu'il pourraient être plus embêtants... Eh bein si.
Le 01/04/2009 à 21h35
Utilisateur
Nb Posts : 9
J'ai réussi a finir le labo d'Agar en utilisant a outrance les bugs et la sauvegarde (ce que j'y ai découvert m'a quand même légèrement déçu après tout ce que j'ai dû ingurgiter comme antidépresseur... Le problème est plus épineux concernant les mages de la forge de gharik... 8-|


Pfff ca me saoule que de tels jeux soit injouables a cause de ce fichus OS qu'on nous force a acheter! Je vais quand même pas devoir m'acheter un deuxieme ordinateur d'occasion pour pouvoir jouer quand même! :-?


Je viens de m'apercevoir qu'Arcanum, un jeu dans le même univers avec un gameplay comme Diablo et que je conseille fortement, me fait la même erreur! (alors que jusqu'a maintenant tout se passait bien!) 8-)

Bon après la nage, j'offre un cours de chute libre a mon ordi! :-(
Le 01/04/2009 à 22h44
  • Ami du Forum
avatar de im_in_fire
Ton placard.
Nb Posts : 538
En fait si le jeu plante avec les yeux et les magiciens, il se pourrait que le problème vienne d'un sprite (image qui bouge rapidement pour créer une animation, précurseur du modèlle).
Oubliez la réalité, ma version des faits est bien meilleure!
http://miminee.labrute.fr
Le 02/04/2009 à 00h31
Administrateur
avatar de Asumbaa
Paris
Nb Posts : 3193
Ben si ça te le fait avec plusieurs jeux (dont Arcanum !! Enfin un amateur !)... C'est le système :-|

T'as pas un vieux XP dans un coin ?
À tout hasard, les pilotes de carte graphique ?
"Le jeu est un défi de l'intelligence à la raison"
Le 02/04/2009 à 00h36
  • Enquêteur
avatar de Ramsès
Toulouse
Nb Posts : 1198
Si le labo a été si dur que ça, c'est même pas la peine d'essayer Darkmoor et Alamos. Genre dans Darkmoor y'a 50 fois plus d'yeux que dans le labo, et c'est à peine exagéré. Mais de toute façon tu peux pas y entrer :P

C'est bête, un tout petit fichier qui défaille et qui empêche de jouer :-/
Le 02/04/2009 à 00h58
  • Ami du Forum
avatar de im_in_fire
Ton placard.
Nb Posts : 538
Ah oups, j'avais pas vû qu'il a des problèmes avec Arcanum aussi :-o . Comme l'as mentionné notre maîtresse bien-aimée, les pilotes de la carte graphique pourraient en être la cause.

En fait, t'aurais pas les "specs" de ton PC par hasard?
Oubliez la réalité, ma version des faits est bien meilleure!
http://miminee.labrute.fr
Le 02/04/2009 à 18h41
Administrateur
avatar de Asumbaa
Paris
Nb Posts : 3193
Autre chose concernant le patch : si tu supprimes le fichier dont il te parles puis que tu appliques le patch ?

(sauve le fichier original quand même... genre renomme-le en [nomDuFichier].bak)
"Le jeu est un défi de l'intelligence à la raison"
Le 02/04/2009 à 22h17
Utilisateur
Nb Posts : 9
Le plus amusant, c'est que j'ai déjà réussi a finir alamos (si darkmoor est pire qu'alamos, purée! qu'est ce que je rate! >_< ) avec la version anglaise(enfin, les menu sont en russe mais les dialogue en anglais...), mais bizarrement, là mon ordi devient de plus en plus capricieux!


J'ai essayé de lancer le programme en mode administrateur, en mode de compatibilité XP SP2, 98, etc... rien a faire, c'est au bon vouloir de l'ordinateur!
Pour le fichier PARTY.CPP, je le trouve pas non plus, mais j'ai un fichier SPRITES.LOD, sinon les anims sont casées dans un fichier "anims1.vid"

Je vais attendre le mois prochain, lors de ma resto de systéme trimestrielle, voir si le probleme se regle de lui même sinon je vais essayer de denicher une 3 ème version, francaise si possible, qui fonctionnera....Pour le moment je laisse tomber! Pas envie de gâcher ma bonne humeur légendaire pour "petitmou"

Pour info:
processeur Intel Core 2 duo CPU T7300 @2.00GHz 2.00 GHz

Mémoire vive: 2038Mo
Type du système: Système d'exploitation 32 bits

Carte graphique: NVIDIA GeForce 8600M GS (pas d'autre info visible :s )
Pas de pilotes car j'ai pas le CD de Vista! Les vendeurs n'ont pas jugé utile de me fournir ce CD au cas où j'aurais un ennui avec lui.

Je vais voir, par contre pour le patch mais il me semble que j'ai deja cherché ce fichier sans le trouver! Raaah si seulement mon frere n'avait pas paumé le CD original! (quoique...même pas sûr que ca fonctionnerai mieux mais au moins il serait installé proprement!)

Je vais me rachter un ordinateur! Même s'il faut payer 50¤ (!)en plus pour avoir XP, ca me fera economiser des anti-dépresseurs!

Merci a tous pour vos réponses, puisse ce forum exister pendant treees longtemps! :p
Le 02/04/2009 à 23h37
Administrateur
avatar de Asumbaa
Paris
Nb Posts : 3193
Pas besoin de racheter un ordi pour obtenir XP, quand même ! (si ? ils le vendent plus à part ?)

Les pilotes NVidia se trouvent sur le site de nvidia ; tu connais le modèle de ta carte donc c'est pas souci ça, tu peux aller faire les MAJ. C'est toujours une bonne chose à faire de toute façon ;-)
"Le jeu est un défi de l'intelligence à la raison"
Le 03/04/2009 à 06h32
Utilisateur
Nb Posts : 9
Bah disons qu'il est impossible d'effacer completement vista d'un ordinateur où il a été installé ( petitmou a tout prévu) et deux OS sur le même ordi, ca sent plus le casse tête et l'instabilité qu'autre chose...

Quant a la carte graphique, elle est a jour, je fais les MAJ regulierement au kazoo... :-|
Le 03/04/2009 à 18h46
Administrateur
avatar de Asumbaa
Paris
Nb Posts : 3193
Ben je sèche, alors. Je me suis solennellement promis de ne jamais utiliser Vista sur une machine à moi ;-)

Une dernière idée, peut-être : installer le jeu sur une autre partition, si tu as. Limite un disque dur externe ?
"Le jeu est un défi de l'intelligence à la raison"
Le 03/04/2009 à 19h11
Utilisateur
Nb Posts : 9
Moi aussi, malheureusement je suis né un an trop tard! Maintenant faut payer un supplement pour avoir XP et j'avais déjà largement dépassé le palier autoriser par les parents, a l'époque!

L'installer sur une autre partition? Mais ca sera toujours géré par vista...M'enfin au point où j'en suis je peux bien essayer ^^

Sinon, bah je me rabattrai sur le solitaire...ca va etre le seul jeu qui va fonctionner a peu près normalement! mdr
Le 04/04/2009 à 16h54
iPouf
Tu peux essayer d'émuler windows XP sous windows Vista, si le probléme vient bien de l'os ça sera réglé. Par contre tu risques de perdre de la puissance mais bon...c'est MM6 !
Le 04/04/2009 à 21h59
Utilisateur
Nb Posts : 9
bah disons que lapuissance, c'est principalement pour ça que je l'ai acheté Je peux jouer a counter strike en ligne sans probleme particulier ce qui est rare (pour moi!)
Après, bon faut voir le nombre de jeu qui buggent ... c'est très dur de choisir :s

Might and Magic VI - Problème dans le jeu

Sujet : Oeil Maléfique! grrrrr

23 messages
Aller à la catégorie
Retour haut